NVIDIA Geforce 8200 – Linux Performance

Wie ich ja schon geschrieben habe, schlummert (leider im wahrsten Sinne des Wortes) in meinem neuen Rechner eine Onboard Geforce 8200. Ich habe munter die properitären NVIDIA-Treiber (Version 180) installiert, die mir mein Ubuntu 9.04 Jaunty Jackalope vorgeschlagen hat und alles lief auch auf den erstn Blick – bis auf die Tatsache, dass es irgendwie alles a****lahm war…

Ich habe dann mal testweise die etwas älteren Treiber (Version 173) installiert. Das Ergebnis war, dass alles noch viel viel langsamer war und ich meinen Text(!!)-E-Mails in Evolution beim beim Rendern zuschauen konnte! Furchtbar! Also habe ich erst mal im BIOS experimentiert und z.B. das Shared Memory nach oben geschraubt. Hilft nichts. Wieder den „alten neuen“ Treiber (Version 180) installiert – läuft besser aber nicht toll. Ich war schon kurz davor eine richtige passivgekühlte Geforce zu bestellen…

Heute morgen habe ich allerdings von meinem Kollegen Patrice einen interessanten Thread geschickt bekommen: http://www.nvnews.net/vbulletin/showthread.php?t=115916

Hier mal ein Ausschnitt aus meiner xorg.conf:


Section "Device"
Identifier "Configured Video Device"
Option "NoLogo" "True"
Driver "nvidia"
#Option "PixmapCacheSize" "1000000"
Option "PixmapCacheSize" "300000"
Option "OnDemandVBlankInterrupts" "True"
Option "AllowSHMPixmaps" "0"
Option "InitialPixmapPlacement" "2"
Option "GlyphCache" "1"
EndSection

Der Wert von „PixmapCacheSize“ wird in diversen Foren „mal so und mal so“ angegeben. Mit den 300000 läuft es inzwischen aber ganz anständig. Alleine Compiz zickt noch rum und lässt gerne mal den X abstürzen, z.B. wenn ich größere Bilddateien öffne. :-(
Ich werde in den nächsten Tagen mal dem o.g. Thread folgen und auch die neuesten NVIDIA-Treiber herunterladen und von Hand installieren. Wenn’s was hilft, sage ich Bescheid! ;-)

War dieser Artikel hilfreich für Sie?
[Gesamt: 0 Durchschnitt: 0]

5 thoughts on “NVIDIA Geforce 8200 – Linux Performance

  1. Crow1985 sagt:

    Moin,

    stehe auch kurz davor Ubuntu 9.04 auf meinem Rechenknecht zu installieren. Tja und ebenso wie bei Ihnen werkelt eine Geforce 8200 unter der Haube.
    Nun habe ich aber schon einiges an Problemen bezüglich Geforce 8200 und Ubuntu gelesen, eben die hier beschriebenen Performanceprobleme, speziell im 2D-Modus.
    Sie sagen mit den Einstellungen in Ihrer xorg.conf läuft alles ganz ordentlich.
    Was kann ich mir darunter vorstellen? Probleme mit Compiz würden mich nicht stören, möchte ich eh nicht unbedingt nutzen.
    Wie es mit der Installation per Hand geklappt würde mich trotzdem interessieren.;)

    MFG

  2. Ronald sagt:

    Hallo Crow, danke für den Beitrag. Also mit den Settings der xorg.conf läuft nun alles „schnell“. Ich habe noch ein Notebook mit einer Radeon X1400 mit aktiviertem Compiz. Ohne irgendwelche Benchmarks o.ä. gemacht zu haben, sehe ich da jetzt keine Unterschiede mehr, es läuft nun alles flott (mit Metacity und der 8200). Die Compiz-X-Server-Abstürzt sind aber leider immer noch vorhanden, d.h. ich muss vorerst ohne Compiz-Effekte auskommen. :-(
    Das händische Installieren des neueren Treibers werde ich in den nächsten Tagen mal ausprobieren.

  3. Crow1985 sagt:

    Ok, danke für die schnelle Rückmeldung. Ich werde es mal wagen und berichten.:)

  4. Crow1985 sagt:

    So habs installiert. Performance war von Beginn an ok, mit dem NVidia 180 sonstwas Treiber. Compiz musste ich aber auch deaktivieren, da es sonst recht unstabil lief. Gerade beim öffnen von Seiten mit vielen Bildern.
    Ok das Compiz nicht läuft ist für mich zu verschmerzen.

    Sehr viel mehr beunruhigt mich das:

    Log of fsck -C3 -R -A -a
    Tue May 12 21:42:56 2009
    
    fsck 1.41.4 (27-Jan-2009)
    open UUID=2649-B937:No such file or directory
    dosfsck 3.0.1, 23 Nov 2008, FAT32, LFN
    /dev/sda3: recovering journal
    /dev/sda3: clean, 607/26451968 files, 1719380/105782000 blocks
    /dev/.tmp-block-8_21: recovering journal
    fsck.ext3: No such file or directory while trying to re-open /dev/.tmp-block-8_$
    e2fsck: io manager magic bad!
    fsck died with exit status 9
    
    Tue May 12 21:42:57 2009
    

    Scheint irgendwie Probleme mit dem File-System oder den Rechten zu geben.

  5. […] dem Artikel NVIDIA Geforce 8200 – Linux Performance berichtete ich ja von den erbärmlichen Verhältnissen mit meinem neuen Barebone respektive meiner […]

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *